Monday, August 30, 2021

Sunday, August 1, 2021

ICYMI : A Self Hosted Standalone ("Weightless") Instance Of Hixie's Data URI Kitchen -- Because Base64, Natch!

 I found it here.  This Simon Willison must be a God of some sort.  Surely he does not want for everry hedonistic pleasure.  if he does prhaps he shouldd contact me to see if he is compatible.  if not then at least for an awesome home cooked meal and hella effin rockin coffee or tea.  Because he must be a God of some sort. Perhaps of the same race as Hixie Of The Hearth Divine Beloved Of Feline. 

Of course I extend the same invitation, even more earnestly, to the Elder of these two.  

But I wouldn't importune.  

(& the List of those so invited is not short; I am lucky to be alive at the same time as these Divine Ones).

Enough.  No one reads this blog.  Here is a data kitchen which may suffice where others do not.



for fun some old friends and an old fashioned Hixie:

Data URLs in Tiny Hack20wn Packages







Type application

For Multipurpose files.

  • application/atom+xml: Atom feeds
  • application/EDI-X12: EDI X12 data; Defined in RFC 1767
  • application/EDIFACT: EDI EDIFACT data; Defined in RFC 1767
  • application/json: JavaScript Object Notation JSON; Defined in RFC 4627
  • application/javascript: JavaScript; Defined in RFC 4329 but not accepted in IE 8 or earlier, however text/javascript is accepted.
  • application/octet-stream: Arbitrary binary data.[4] Generally speaking this type identifies files that are not associated with a specific application. Contrary to past assumptions by software packages such as Apache this is not a type that should be applied to unknown files. In such a case, a server or application should not indicate a content type, as it may be incorrect, but rather, should omit the type in order to allow the recipient to guess the type.[5]
  • application/ogg: Ogg, a multimedia bitstream container format; Defined in RFC 5334
  • application/pdf: Portable Document Format, PDF has been in use for document exchange on the Internet since 1993; Defined in RFC 3778
  • application/postscript: PostScript; Defined in RFC 2046
  • application/soap+xml: SOAP; Defined by RFC 3902
  • application/x-woff: Web Open Font Format
  • application/xhtml+xml: XHTML; Defined by RFC 3236
  • application/xml-dtd: DTD files; Defined by RFC 3023
  • application/xop+xml:XOP
  • application/zip: ZIP archive files; Registered[6]
  • application/x-gzip: Gzip

Type audio

For Audio.

Type image

Type message

Type model

For 3D models.

Type multipart

For archives and other objects made of more than one part.

Type text

For human-readable text and source code.

Type video

For video.

Type vnd

For vendor-specific files.

Type x

For non-standard files.

Type x-pkcs

For PKCS standard files.

  • application/x-pkcs12: p12 files
  • application/x-pkcs12: pfx files
  • application/x-pkcs7-certificates: p7b files
  • application/x-pkcs7-certificates: spc files
  • application/x-pkcs7-certreqresp: p7r files
  • application/x-pkcs7-mime: p7c files
  • application/x-pkcs7-mime: p7m files
  • application/x-pkcs7-signature: p7s files
have fun

Monday, July 26, 2021

Sunday, July 18, 2021

a manual textise to render as text recalcitrant -- and obstinate -- web pages

Some times you'll want to render some pages as text only.  Some pages think they have a right to refuse.  Some people, like the author, find it really difficult to take no for an answer — from any software, but especially from a large corporation.

Think mainstream media, larger search engines, &c...

---------------------------------------------------------------------------------------------------

For the Recalcitrant Page:

Enter URL below, load frame, find an innocuous spot to inset cursor, click, select all, and paste into textarea, tap the button, & lo and behold! text.  text sometimes without all the unnecessary things that load after the page and often prevent optimal viewing.

-----------------------------------------------------------------------------

For the Obstinate Page:

(such as a top tier search, video, image, or music engine):

Enter URL below, and note how when you load frame, some text appears below that starts with "curl." Select that text, and paste where it says "curl" in the iframe at the bottom of the page. Tap the button to run it, wait a sec, & lo and behold! the frame for you to... find an innocuous spot to inset cursor, click, select all, and paste into textarea, tap the button, & lo and behold! text.  text sometimes without all the unnecessary things that load after the page and often prevent optimal viewing. 

Apologies if you thought it was going to be formatted. At least all the thingies are resizeable (or ought to be, dammit).

But wait!  There's more!  Still unhappy because untextified? 

Scroll to the UPDATE, let us experiment with the PDF creator! 

There ought to be a viewer just below it, so you can see what you just created, scroll, copy text, paste it in that now familiar orange textarea, tap Ye Olde Button, & lo!  Behold! 
----------------------------------------------------------------------

⌨️⌨️⌨️⌨️⌨️⌨️⌨️⌨️⌨️

ENJOY YOUR NEWFOUND READING MATERIAL.

or, go to Faust's hella WYSIWYG to download any way you please.

⌨️⌨️⌨️⌨️⌨️⌨️⌨️⌨️⌨️

EVERY PAGE STARTS HERE:

URL:


OBSTINATE COPY THESE WORDS, PASTE IN WINDOW BELOW, THEN PASTE INTO TEXTAREA  (SEE INSTRUCTIONS ABOVE):



THE TEXTISING TEXTAREA:


-------------------------------------------------

MAYBE GOOGLE CACHE TEXT ONLY WILL WORK:

Paste your URL and a new link should appear below to open the cached page in a new tab. 

DO NOT TO INCLUDE THE HTTP OR HTTPS (INCLUDING COLON AND SLASHES). 

DO NOT INCLUDE ANY UNNECESSARY PARAMETERS.  If it does not work, remove parameters.

Then just click through to your text only page -- if the regular cache was all that loaded. Tap and hold, or right-click to download.  URL:

Remember, this only works because it is Google's domain -- don't try to click through, it will un-cache you.  Maybe try using a web archive like Archive.org, with a very recent version of the page you want.  You could even MAKE a version.  That might could work.  Or maybe if you sandboxed that... But I digress.

-------------------------------------------------------------

.UPDATE

A PDF Creator where you can paste the URL of that really obstinate page! Then just scroll down to view and copy text (hopefully I added that utility), or just view it as you would another PDF.



BCNU.